#184 Aechor Plant Breaks with Any Animated Spawners Rendering it

Closed
opened 1 year ago by jredfox · 1 comments
jredfox commented 1 year ago

entities use ticksExisted( which does increment for my mob spawners) only for passive animations. The Aechor plant seems to require an Entity#onUpdate() in order to render but, for mob spawners this simply doesn't happen as spawning in a client only entity with the location and angles even if it's defaulted to 0,0,0,0.0f,0.0f will result in things breaking. So mob spawners if they animate entities passive animations will call Entity#ticksExisted++ instead.

I did a test though even though I knew it would break. I called Entity#onUpdate manually with my spawners and the aechor plant was still shaking. I also commented out my setting location and angles of the entity on tick.(both separate builds of the mod since no deob jar was found and aether jars don't work ind deob currently). Anyways both of them resulting in the entity still shaking so please fix this issue thanks for your time

My TESR renderer: https://github.com/jredfox/silkspawners_rewrite/blob/master/src/main/java/com/evilnotch/silkspawners/client/render/tileentity/MobSpawnerStackBase.java

entities use ticksExisted( which does increment for my mob spawners) only for passive animations. The Aechor plant seems to require an Entity#onUpdate() in order to render but, for mob spawners this simply doesn't happen as spawning in a client only entity with the location and angles even if it's defaulted to 0,0,0,0.0f,0.0f will result in things breaking. So mob spawners if they animate entities passive animations will call Entity#ticksExisted++ instead. I did a test though even though I knew it would break. I called Entity#onUpdate manually with my spawners and the aechor plant was still shaking. I also commented out my setting location and angles of the entity on tick.(both separate builds of the mod since no deob jar was found and aether jars don't work ind deob currently). Anyways both of them resulting in the entity still shaking so please fix this issue thanks for your time My TESR renderer: https://github.com/jredfox/silkspawners_rewrite/blob/master/src/main/java/com/evilnotch/silkspawners/client/render/tileentity/MobSpawnerStackBase.java
bconlon commented 5 months ago
Collaborator

Aechor Plants now render correctly in spawners as of the latest versions, so this has been fixed.

Aechor Plants now render correctly in spawners as of the latest versions, so this has been fixed.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.